Compatibilité audio video des clients XMPP

De Wiki JabberFR
Aller à : navigation, rechercher

/!\ Ébauche /!\

Infos en vrac:

Page née du fait que c'est apparemment une bonne idée (et que j'ai aussi besoin de ce type d'infos): http://forum.jabberfr.org/viewtopic.php?id=2007

Depuis http://wiki.jabberfr.org/Jingle : À cette heure (2011), Jingle permet la voix dans le service Google Talk avec le client officiel ainsi que les clients Jabber libres Coccinella, Empathy, Gajim, Jabbin, Kopete, Pidgin, Psi, Jitsi, OneTeam et Spark ainsi que le serveur Jabber libre Openfire et l’IPBX libre Asterisk.

Note: les résultats des tests de compatibilité seraient dépendants de: la version du logiciel, le nom du client, le système d'exploitation ... un peu emmerdant du coup. Plutôt assumer: la dernière version du logiciel en date. Et donc est-ce qu'on distingue Psi Win / Psi Lin ... ? (ou bien on appose éventuellement une note pour dire: test réalisé entre un poste Linux et Windows ...). On pourrait apposer plusieurs notes pour chaque tests (numérotés) réalisés, chacune étant liées à un rapport, qu'on écrirait en bas de page avec les infos qu'il faut (OS/version/date...).

Un article: http://tuxicoman.jesuislibre.net/2012/09/video-conference-multiplateforme-avec-jabber.html (lien mort ou auto-hébergé, je le recopie en attendant):


 Le moyen le plus simple pour faire de la visio-conférence multiplateforme avec Jabber est la combinaison Empathy[1] (linux) et Gtalk[2] (mac, windows, linux).
 Pour une conversation entre deux Empathy sous Linux, pas de soucis, ca marche du premier coup sans configuration.
 Afin que la vidéo fonctionne lors d'une conversation Empathy vers Gtalk, l'ordinateur sous linux devra avoir installé un codec x264 pour gstreamer.
 Celui-ci n'est pas présent dans les dépôts par défaut des distributions pour des raisons de brevets.
 Pour Debian[4] Squeeze, il faut ajouter le dépôt deb-multimedia[5] et installer le paquet gstreamer0.10-x264.
 Cependant, la visioconférence avec Jabber reste encore peu utilisée.
 Plusieurs raisons à cela :
 * Jabber n'a pas percé comme réseau de communication ouvert. XMPP s'est déployé mais chaque réseau st fermé (Facebook par ex)
 * Lincompatibilité fonctionnelle entre les clients. Chaque client a des fonctions différentes suivant l'orientation du logiciel. Certains ne supportent pas
   les salons (groupchat), d'autres le transfert de fichier ou le chiffrement OTR. Si bien que le dénominateur commun  entre 2 personnes utilisant 2 clients
   Jabber différents se résume souvent aux seuls messages texte.
 * Le manque de logiciels client multiplatefome permettant la visioconférence et compatibles découle de la remarque précédente.
 * La galère pour trouver la bonne combinaison de logiciels qui fonctionne entre eux est rebutante.
 Liens:
 [1]: https://live.gnome.org/Empathy (lien)
 [2]: http://www.google.com/talk/intl/fr/ (lien)
 [3]: https://wiki.jabberfr.org/Fichier:Rnusers.empathy.png (lien)
 [4]: http://www.debian.org/ (lien)
 [5]: http://deb-multimedia.org/ (lien)