Différences entre versions de « Version du logiciel »

De Wiki JabberFR
Sauter à la navigation Sauter à la recherche
(Protocole : Software-version)
 
Ligne 1 : Ligne 1 :
 
=En bref=
 
=En bref=
Le « [http://www.jabber.org/jeps/jep-0092.html JEP-0092: Software Version] » définit comment retrouver la version du logiciel sous-jacent à une entité du réseau. Il est possible de retrouver :
+
Jabber permet de retrouver la version du logiciel utilisé par une entité du réseau. Il est possible de retrouver :
 
* le nom du logiciel (champs obligatoire) ;
 
* le nom du logiciel (champs obligatoire) ;
 
* la version du logiciel (champs obligatoire) ;
 
* la version du logiciel (champs obligatoire) ;
 
* le système d'exploitation sur lequel tourne le logiciel (champs optionnel).
 
* le système d'exploitation sur lequel tourne le logiciel (champs optionnel).
 +
 +
[[Image:Version_du_logiciel.png]]
 +
 +
Le protocole associé est le « [http://www.jabber.org/jeps/jep-0092.html JEP-0092: Software Version] ».
  
 
=Pratiques courantes=
 
=Pratiques courantes=
Ligne 11 : Ligne 15 :
  
 
=Clients supportant ce protocole=
 
=Clients supportant ce protocole=
* [[Gaim]] 1.5 : Non
+
* [[Gaim]] 1.5 :
* [[Kopete]] 0.9.2 : Non
+
** renvoie la version du logiciel
* [[Psi]] 0.9.3 : Non
+
** ne permet pas de la demander
 +
* [[Gajim]] 0.8 : OK
 +
* [[Kopete]] 0.9.2 :
 +
** renvoie la version du logiciel
 +
** ne permet pas de la demander
 +
* [[Psi]] 0.9.3 : OK

Version du 20 août 2005 à 16:39

En bref

Jabber permet de retrouver la version du logiciel utilisé par une entité du réseau. Il est possible de retrouver :

  • le nom du logiciel (champs obligatoire) ;
  • la version du logiciel (champs obligatoire) ;
  • le système d'exploitation sur lequel tourne le logiciel (champs optionnel).

Version du logiciel.png

Le protocole associé est le « JEP-0092: Software Version ».

Pratiques courantes

Ce protocole est utilisé par certains clients pour connaître le client utilisé par un des contacts présent dans le roster. Vous pouvez ainsi savoir si votre contact utilise le même logiciel que vous, la même version, etc.

Le protocole est aussi souvent utilisé pour connaître la version de certains composants sur les serveurs comme des passerelles par exemple.

Clients supportant ce protocole

  • Gaim 1.5 :
    • renvoie la version du logiciel
    • ne permet pas de la demander
  • Gajim 0.8 : OK
  • Kopete 0.9.2 :
    • renvoie la version du logiciel
    • ne permet pas de la demander
  • Psi 0.9.3 : OK